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VHDL ENTITY and ARCHITECTURE
— -~ majority.yote

ENTITY majority_vote IS

PORT tity declarati
a, b, c: IN BIT; . , entity declaration
/\TO y: OUT BIT);} port definjtion
END majority_vote; )

T,

ARCHITECTURE maj_vote OF majority vote IS
Architecture | BEGIN , architecture body
name — y <= (a and b) or (b and c) or (a and c);

END maj_vote;
\/ " majority_ vote

entity name

’ _E} — a y —
= I_D _D Y=AB+BC+AC '_ B
_______________ ¢ 41—} — c |
VHDL is case- msensmve - inst i

Y . / Yuan-Hao Chang
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«Solve Y = AB+AC+D

ACommentJ

-- This Is comment
ENTITY logic_circuit IS Mode
PORT( “Fi Type j

a, b,c,dINBIT,)

y: OUT BIT)O Logic operations:

END logic_circuit;) ~and, or, not, xor, -
| nand, nor |

_________________________

ARCHITECTURE cct OF logic circuit IS
BEGIN % assign |

y <= not ((a and b) or ((not a) and (not c)) or d@
END cct )

Chang
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Modes and Types

BUFFER is the same as OUT, but
- Modes: allows to be fed back to the CPLD
' logic to be reused by another function.

—IN, OUT, INOUT, BUFFER

IN ouT BUFFER
4% —|>'— . % Xx<=aorb;
b
INout CPLD
Logic BUFFER L ouT
D e D> yerams

* Types One bit | [ Multiple bits |
—BIT:

- BIT, BIT_VECTOR
~STD LOGIC:
- STD_LOGIC, STD_LOGIC_VECTOR

—INTEGER Equal or larger than 0 || Equal or larger than 1
) INTEGER’ NATURAL’ POSITIVE Copyright © All Rights Reserved by Yuan-Hao Chang




@

_______________________________________________

d(3) <='0"; d(2) <="1";
. d(1) <='0"; d(0) <="1%;
IN BIT_VECTOR (3 downto O)
| d <="0101"
IN BIT_VECTOR (0 to 3)
d <="1010";

) ) ) ) Chitwise and vec 4 BEGIN -
-- 4-bit bitwise and function _ = _ 5 y0 <= a0 and bO; Outputs i g
--y =aand b; et b[2.0] yl <=al and bl; . d L]
ENTITY bitwise_and_vec_4 IS o\ y2 <= a2 and b2;[ 2°°19N€0 -

PO RT( ..... 1L A .

a, b: IN BIT_VECTOR(3 downto 0)}
y: OUT BIT_VECTOR(3 downto 0));

END and_gate;
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' -- 4-bit bitwise and function
' --y0 =a0 and b0; y1 = al and b1, etc.
'ENTITY bitwise_and_4 IS

PORITI Ports

a0, al, a2, a3 : IN BIT,;

b0, b1, b2, b3 : IN BIT; (defined
y0, y1, y2, y3: OUT BIT); |nd|V|duaIIy

END bitwise _and_4;

- ARCHITECTURE and_gate OF bitwise_ and 4 IS _

abadiald

y3 <= a3 and b3; individually |

END bitwise_and_vec_4; -----=" s d| de) | d@) | a1 | do | m ] i
. Ports defined as vectors @ : =
——————————————————————————————————————— a) d (3 downto 0 Y2

ARCHITECTURE and_gate OF bitwise_and_vec 4 IS o2

BEGIN _ S

y <= a and b;} Outputs assigned as a vector | 4 | dn | 4@ | d3) | .

END and_gate; ngyﬂégttagl—%? Rights Heserve(ﬁ)y Yuan-Hao Chang
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WITH ... SELECI
S, D, Dy Do | ¥ ENTITY select_example IS
0 0 0 0 0
0 0 0 1 0 PRI
d: IN BIT_VECTOR(3 downto 0);
0o 0 1 0 | O | |
00 1L L et example; | Selecty based on d
0 1 0 0 0 END select_example; | =€ © ){ ____________________ )
0 1 0 1 0
0 1 1 0 1 ARCHITECTURE: c_c;_t__(_)_F_g,_e__I_e_pt example IS
o 1 1 1| o BEGIN = d@3) | d©)
1 0 0 0 0 WITH d SELECT e
1 0 0 1 1 y <='1'WHEN "0011",
1 0 1 0 0 '1' WHEN "0110",
1 0 1 1 0 '1' WHEN "1001",
1 1 0 0 1 'l' WHEN "1100", e e
1 1 0 1 0 'Qi_\_/_VH_I_E_I_\_I__Q’ghQ_rjg. ==, Defaultis
1 1 1 0 0 END cct;  value of y __required |
1 l 1 1 O ‘_é;););/;(g_h_t_é:A_II_EUghts Reserved by Yuan-Hao Chang
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STD LOGIC and STD LOGIC VECTOR

«STD LOGIC is also called
IEEE Std.1164 Multi-
Valued Logic

*Touse STD_LOGIC, we
must include the package:

LIBRARY ieee; |
'USE ieee.std logic_1164.ALL;

Uninitialized

Forcing Unknown

Forcing O

Forcing 1

High Impedance

Weak Unknown

Weak O (pull-down resistor)
Weak 1 (pull-up resistor)
Don't Care

Copyright © All Rights Reserved by Yuan-Hao Chang
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STD LOGIC and STD LOGIC_VECTOR (Cont.)

LIBRARY ieee;
USE ieee.std logic_1164.ALL,;

ENTITY bitwise_and _std 4 IS
PORT(
a, b:IN STD LOGIC VECTOR(3 downto 0);
y: OUT STD_LOGIC_VECTOR(3 downto 0));
END bitwise _and_std 4;

ARCHITECTURE and_gate OF bitwise _and_std 4 IS
BEGIN

y <=aand b;
END and_gate;

A3

A2

Al
B1

A0
BO

TTTY

e

Y1

Copyright © All Rights Reserved by Yuan-Hao Chang
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Tristate

LIBRARY ieee;
USE ieee.std logic_1164.ALL;

ENTITY quad_tri IS
PORT(
a:IN STD LOGIC VECTOR(3 downto 0);
g:IN STD_LOGIC;
y: OUT STD_LOGIC_VECTOR(3 downto 0));
END quad_tri;

ARCHITECTURE quad_buff OF quad _tri IS
BEGIN
WITH g SELECT
y<= a WHEN '0',
"ZZ77Z" \WHEN others;
END quad_buff;

April 14, 2011

YL Y2 Y3 Y4 | G

Al A2 A3 A4 0

VA VA VA VA 1
A1 \E Y1
A2 \[ Yo
A3 \E Y3
A4 \E Y4

G

Copyright © All Rights Reserved by Yuan-Hao Chang
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INTEGER 'LIBRARY ieee;

- USE leee.std_logic_1164.ALL;

'ENTITY truth_table IS

LIBRARY ieee; ~ PORT( -
USE ieee.std_logic_1164.ALL; - d:IN STD_LOGIC_VECTOR(2 downto 0); |
.~ y:OUT STD_LOGIC); |
ENTITY truth_table IS ' END truth_table; i
PORT( - g
d:IN  INTEGER RANGE O to 7; ARCHITECTURE a OF truth_table IS i
y: OUT STD_LOGIC); ' BEGIN 5
END truth_table; i WITH d SELECT D, D, Do | ¥
Cy<= T wWHEN<001", [©Q O OO
ARCHITECTURE a OF truth_table IS ‘! WHEN “101”, 0O 0 1]1
BEGIN : ‘1" WHEN “110", 0O 1:01/0
WITH d SELECT | ‘0" WHEN others; 0o 1 110
y<= ‘1 WHEN 1, 'END a; |
el WHENS5,~._ e 1020710
Sl WHEN 6, oo 1 0 1)1
0 WHEN others; T 1 1 0|1
ENDa; . . mteger 1 1 110

Copyright © All Rights Reserved by Yuan-Hao Chang
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SIGNAL
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* SIGNAL can bundle inputs or outputs into a single group.

' LIBRARY ieee;
- USE ieee.std_logic_1164.ALL;

ENTITY signal_ex IS
. PORT(
a,b,c: IN STD_LOGIC,;
. W, XY, z:0UT STD_LOGIC);
. END signal_ex;

- ARCHITECTURE sig OF signal_ex IS

. -- Declaration area

-- Define signals here

SIGNAL inputs : STD_LOGIC_VECTOR(2 downto 0);

SIGNAL outputs: STD_LOGIC_VECTOR(3 downto 0); |

' BEGIN
-- Concatenate input ports into 3-bit signal
inputs <=a & b & c;

SIGMNAL SIGNAL
\

— N LA

N — W N
A — Y / x.f
NN ¥ L X
PORTS | B inputs[2. . O] outputs[3. . 0] —ﬁ* i I

c N

v
|! WITH inputs SELECT ABCIWXY Z
outputs <= : 0 00[2 000
"1000" WHEN "000", 1 |0 0 1|0 1 0 O
"0100" WHEN "001",: [0 1 0|0 1 1 O
"0110" WHEN "010",§ 01 1(1 0 0 1
"1001"WHEN "011", ' |1 0 0|/0 1 1 O
‘ooor" whien 1oz, | |1 0 2[© 0 0 2
"1001" WHEN "110", 11011001
"0010" WHEN "111", ' 1110010
i "0000" WHEN others;i
|1 -- Separate signal '
- W <= outputs(3);
|1 x <= outputs(2);
|| y <= outputs(1);
|z <= outputs(0); j
—END sig; o inputs(2) inputs(1) inputs(0)
inputs a b c
PORTS outputs_(é_)"_o_utputs(z) outputs(1) outputs(0)

outputs w X y z
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Single-Bit SIGNAL

Y =AB+AB+CD
‘ axor_b
PORTS | B —e{>o——
o> v

--Combine single-bit and multiple-bit S|gnals

d:IN STD_LOGIC_VECTOR(2 downto 0);
enable: IN STD_LOGIC;

'SIGNAL inputs: STD_LOGIC_VECTOR (3 downto 0);

inputs <= enable & d; -- combine
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LIBRARY ieee;
USE ieee.std_logic_1164.ALL;

ENTITY signal_ex2 IS
PORT(
a,b,c,d:IN STD LOGIC;
y : OUT STD_LOGICO);
END signal_ex2;

ARCHITECTURE cct of signal_ex2 IS
-- Declare signal
SIGNAL a_xor_b: STD LOGIC,;

BEGIN
-- Define signal in terms of ports a and b
a_xor_b <= ((not a) and b) or (a and (not b));
-- Combine signal with ports ¢ and d
y <=a_xor_b or ((not c) and d);

END cct;

Copyright © All Rights Reserved by Yuan-Hao Chang
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/-Segment Control

|G
LIBRARY ieee;
USE ieee.std logic_1164.ALL; HEX0_DS HEX0_D1
HEX0_D6
]

ENTITY SevenSegment Is

PORT ( HEX0_ D4 HEX0_D2
sw: IN STD_LOGIC_VECTOR(2 downto 0);

pb: IN STD_LOGIC,;

. HEX0 DP
hex0: OUT STD_LOGIC_VECTOR(O to 7)); HEX0_D3
END Labé; o ow@) | e
P T ew(l)
ARCHITECTURE a OF SevenSegment IS “: T e =
BEGIN HEX0_D[0] PIN_E11
WITH pb & sw SELECT § | ccsssont sw(0) | HEX0_D[1] PIN_F11
hex0 <= "00000011" WHEN "0000", HEX0_D[2] oI HI2
"10011111" WHEN "0001", — —
"00100101" WHEN "0010", HEXD_Df3] PIN_H13
"00001101" WHEN "0011", HEX0_D4] PIN_G12
"10011001" WHEN "0100", HEXD DiB] ——
"01001001" WHEN "0101",
"01000001" WHEN "0110", HEX0_DIeI PIN_F13
"00011111" WHEN "0111", HEX0_DP PIN_D13

“11111111" WHEN others;

END a; Copyright © All Rights Reserved by Yuan-Hao Chang
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VHDL Design with Quartus Il

« Example: When the BUTTONQO is pressed,
— LEDGO shows the ANDed result of SWO0 and SW1.
— LEDG1 shows the ORed result of SWO0 and SW1.

« Step 1: Start a new project
— Select File - New Project Wizard
- Working directory: Class6
- Project name: Class6
- Top-level design entry: Class6
— Family & Device Settings
- Device family: Cyclone Il
- Available device: EP3C16F484C6
— EDA Tool Settings
- Leave it alone at the moment

New Project Wizard: Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation.

Device family

Eamiy: | Cpclone Il ~|
Target device

" Auto device selected by the Fitter

(s Specific device selected in ‘Available devices' list

Shaow in ‘Bvailable device' list

Package: ’m
Fin court: ’m
Speed grade: m
[ Show advance d devices

~

Axailable devices:

I arne | Core v.. | LEs | User 14... | Memar... | Embed... | PLL L
EP3CIEF 25647 1.2 15402 169 516098 112 4
EP3C1EF256CE 1.2 15408 169 516096 112 4
EP3C1EF256C7 1.2 15408 169 516096 112 4
EP3C1EF256CH 1.2v 15408 169 518098 112 4
EP3CIEF25EI7 1.2 15408 169 516098 112 4

EP3CTEF 43447 1.2 15402 47 S1E09E 112 4
{EP3ACTEF484CE 1.2 15408 247 B1E09E 112 4 1
FPIATTRFARACT 1 1RANA M7 R1FRNGFR 112 4 _.v.

=

<Buk | [ Wea> | Fmsh | Eug |

Copyright © All Rights Reserved by Yuan-Hao Chang
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VHDL Design with Quartus Il (Cont.)

« Step 2: Design entry using the text editor
— Select File > New - VHDL File (.vhd)
— Save as “Class6.vhd” (check “Add file to current project”)
— Edit “Class6.vhd”  gnTiTY Classé IS

PORT(
A: IN BIT_VECTOR(1 downto 0);
C: IN BIT;
X: OUT BIT;
Y: OUT BIT);
END Classe6;

ARCHITECTURE and_or OF Class6 IS
BEGIN
X <= A(1) and A(0) and (not C);
Y <= (A(1) or A(0)) and (not C);
END and_or;
— Select “Start Compilation” to compile the circuit

Copyright © All Rights Reserved by Yuan-Hao Chang
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VHDL Design with Quartus Il (Cont.)

« Step 3: Simulation with Vector Waveform File (.vwf)
— Select File > New - Vector Waveform File (.vwf)
— Save as “Class6.vwf” (check “Add file to current project”)

— Select “Edit = Insert =2 Insert Node or Bus = Node Finder” to add
iInput/output pins into the simulation.

— Select “Edit > End Time” and select “Edit = Grid Size” to config the
simulation period and count period. (e.g., 4us, grid size: 50ns)
- A(0): count value, binary, count every 50ns, multiplied by 1. i
- A(1): count value, binary, count every 50ns, start time: 20ns, multiplied by 2.
- C: forcing high or forcing low. & &
— Select “Start Simulation” to simulate the circuit.

— Functional simulation o [l e e EEe
- Select “Assignments > Settings > 1y e s v
Simulator Settings” to set T I e
“Simulation mode” as Functional. 5| v so[[ 7 ] ] ] T

- Select “Processing - Generate
Functional Simulation Netlist”

- Select “Start Simulation” to simulate the circuit. |
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VHDL Design with Quartus Il (Cont.)

o Step 3: Simulation with Vector Waveform File (.vwf)

— Select “Assignments - Device” to configure the board settings.
- Set Family as Cyclone Ill and Device as EP316F484C6

- Select “Device and Pin Options”
- Select and set “Unsigned Pings” as “As input tri-stated” and

- Select “Configuration” to set configuration scheme as “Active Serial” and configuration device as
“EPCS4”

— Select “Assignments - Pins” to activate the “Pin Planner”.
— Select “Start Compilation” to compile the circuit with circuit assignment.
— Select “Tools - Programmer” to download the .soft file to the FPGA board for

testing.
Eme 1D bl Lo Do Lo T e x|
Mode Mame Direction Location oSty = o — e ——
Al Input PIN_HS e e b e R ETEE]
AL Input PIN_J5 =
B C Input PIN_HZ =
Lo S Qukput PIN_J1 =
oD U B PIN_12 =

Copyright © All Rights Reserved by Yuan-Hao Chang
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AN <
Lab 6 N
Combinational == —wv—b"—

Logic Circuit e v 2.

e Part 1 - Simulation s P <
— Use VHDL to design a NAND gate  Pressto e”ab'ex | .

with one output pin f and two input BUTTOND
ins a and b. Then use Vector EI Input
sSw2 swi1 swo

aveform File (.vwf) to simulate the
- A: count value, binary, simulation period=4us, advanced by 1 every 100ns
- B: count value, binary, simulation period=4us, advanced by 1 every 200ns

e Part 2: When the BUTTONO is pressed,
— LEDGO shows the ANDed result of SWO0 and SW1.
— LEDG1 shows the ORed result of SW0 and SW1.

* Part 3 - Transferring a Design to a Target FPGA

— Use three slides (SW2-SWO0) as the binary input value. Solve the following
problems with VHDL.

- The corresponding LED (LEDGO-7) is on when selected by the binary input. Other
LEDs are off. E.g., 100 (SW2-SWO0) lights LEDGA4.

- The first 7-segment LED (HEXO) shows the decimal value of the binary input when
the first pushbutton (BUTTONQO) is pressed. Otherwise, HEXO is off. E.g., When
BUTTONO is pressed and the binary input is 101 (SW2-SWO0), HEXO shows 5.

Copyright © All Rights Reserved by Yuan-Hao Chang
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% Pin number Cycione™m
Bgli \|-\|:2 D2 E4 E3 H7 J7 G5 G4 H6é HS5 J'é,
G3 C_w:lone?m

@
§§§

F1

SW9 SW8 SW7 SWe SWs SW4 SW3 sw2 SW1 SWO

3 Pushbutton switches: 10 Slide switches (Sliders):
Not pressed - Logic High Up - Logic High
Pressed - Logic Low Down - Logic
SWI[1] PIN_H5 SW[6] PIN_H7
BUTTON [0] PIN_ A2 SWI[2] PIN_H6 SWI7] PIN_E3
BUTTON [1] PIN_ G3 SWI3] PIN_G4 sSwis] PIN_E4
BUTTON [2] PIN_ F1 SW[4] PIN_G5 SW[9] PIN_D2
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LEDS 10 LEDs

-------------------------- Opuput high - LED on

Pin number ,5 Output low = LED off
Cyclnne?’ﬂlr
LEDGD
LEDGO > _
) VWV :m LEDGIO] PIN_J1
2 | S AN s
LEDG2 LEDG[1] PIN_J2
LEDG2 2
J3
LEDG3 A | EDG3 LEDGI[2] PIN_J3
H1 x
LEDG4 YW LED-:l‘-i LEDG[3] PIN_H1
F2 [ o
VW :ﬁ LEDGI[4] PIN_F2
=y | LEDGS s
LEDE LEDGI5] PIN_E1
LEDGE 6
- VW EDGT LEDG[6] PIN_C1
LEDGT ;
Ax
- VWV  EDGE LEDG[7] PIN_C2
LEDGS ;
oo A
~ WV LEDG[8] PIN_B2
LEDGS EDGY
A
> VWV L LEDGI9] PIN_B

Copyright © All Rights Reserved by Yuan-Hao Chang



/-Segment Displays

April 14, 2011

\_‘_(active-low)

id

_

HEX0_DO
D <
HEX0 D5 HEX0 D1
Pl |
HEX0 D6
L
HEX0 D4 HEX0 D2 [&—
‘—
i . HEX0 DP :
HEX0_D3 -
HEX0_D[0] PIN_E11 HEX1_D[0] PIN_A13
HEX0_D[1] PIN_F11 HEX1 D[1] PIN_B13
HEX0_D[2] PIN_H12 HEX1_D[2] PIN_C13
HEX0_D[3] PIN_H13 HEX1_D[3] PIN_A14
HEX0_D[4] PIN_G12 HEX1_D[4] PIN_B14
HEX0_D[5] PIN_F12 HEX1 D[] PIN_E14
HEX0_DI6] PIN_F13 HEX1_D[6] PIN_A15
HEX0_DP PIN_D13 HEX1_DP PIN_B15

Z o
- - -
- --

-

\
1
1
|
|
1
1
1
1
1

)

 HEX0_D2 H12

 HEX0 D3 H13

1S3
o Cycilonet™ Il

“"HEXo0 D5 ¢12

. HEX0 D6 zi

« HEX0_DP D13
HEX2_D[0] PIN_ D15 HEX3_D[0] PIN_B18
HEX2_D[1] PIN_A16 HEX3_D[1] PIN_F15
HEX2_D[2] PIN_B16 HEX3_D[2] PIN_A19
HEX2 D[3] PIN_E15 HEX3_D[3] PIN_819
HEX2_D[4] PIN_A17 HEX3_D[4] PIN_C19
HEX2_D[5] PIN_B17 HEX3_D[5] PIN_D13
HEX2_D[6] PIN_F14 HEX3_DI6] PIN_G15
HEX2 DP PIN_A18 Rights HEX3_DP PIN_G16
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